The Apijs module for Magento

5.3.0

Contents

  1. Module presentation
    1. Description
    2. Access and configuration
    3. ?4
    4. ?5
    5. Installation and uninstallation
  2. Module download
  3. Support
Magento logo

Don't forget that the present documentation is only about the latest version of the module.
Don't forget to read this page entirely.

Module presentation

Description

Integrates apijs JavaScript library into Magento.
For more information about the library, go to luigifab.fr/apijs.

This module allows:

Access and configuration

Configuration available in System » Configuration » Tools » Dialogs boxes.
Available anywhere, especially in

?4

Le programme JavaScript ne fonctionne pas avec les très anciens navigateurs. Pour éviter des bugs lorsque l'utilisateur utilise un vieux navigateur, un bandeau rouge (front-office et back-office) apparait incitant l'utilisateur à mettre à jour son navigateur.

Sur ce bandeau, il y a l'id oldBrowser qui stop le chargement du programme JavaScript.
Pour tester, il suffit d'ajouter ?browser à la fin de l'url d'une page.

?5

?11

Installation and uninstallation

Nothing simpler with Magento connect (or by decompressing the module archive in the Magento root).
To get the extension key, don't stop reading :) ...

For uninstallation, having uninstalled the module with Magento connect, all that remains is to erase the configuration:

DELETE FROM core_config_data WHERE path LIKE "apijs/%";

Module download

Extension key: https://www.luigifab.fr/magento/connect/luigifab/Luigifab_Apijs
Download of the latest version: luigifab-apijs-5.3.0.tgz (md5 86695d82fe923b484b10129ec5eb26ea)
See also: github.com

The channel already exists? Don't panic, run the following command and try again: php downloader/mage.php channel-delete luigifab

5.3.0
Tested with Firefox 22/45, Chrome 29/55, Opera 42, Edge 14 on Magento 1.4.1.0 with PHP 7.2 and MariaDB 10.1.
Tested with Firefox 45 on Magento 1.5.0.1 / 1.6.0.0 / 1.7.0.0 / 1.8.0.0 / 1.9.0.0 / 1.9.3.9 with PHP 7.2 and MariaDB 10.1.
5.4.0
Tested with Firefox 27/45, Chrome 69, Opera 56, Edge 14 on Magento 1.9.3.10 with PHP 7.0 / 7.1 / 7.2 / 7.3 and MariaDB 10.1.
Tested with my PHP 7 patch.

Support

A problem? A question? Is something not working? Is there a bug? Contact me (in French or in English), if I am not on holiday and not far from my mailbox, I will answer you within a few hours.

You will find my email address in the README file, read it!

This module is not available on magento narketplace.
Why? Because this module, has never worked, does not work, and will never work, with PHP 5.4 and 5.5.
Warning! End of 2020, Magento 1 is over. Furthermore, there will be no version of this module for Magento 2.